Version 14 (modified by ab, 6 months ago) (diff)

This is the latest mainboard firmware version that is compatible with V1 puck/elbow/cpi/bootloader.

Firmware Update

To set up for an upgrade you will need a PEAK CAN USB to CAN adapter (provided by Barrett). Plug the DB9 end of the PEAK CAN adapter into a straight through DB9 extender and plug this into the DB9 on the front of the console.

Version check

By typing

burt-util mainboard get_versions

You should get

Mainboard Version: 1.6.1 (3fce96e)
Puck 1: 1.11.0
Puck 2: 1.11.0
Puck 3: 1.11.0
Elbow: 0.3.3
CPI: 0.0.0

if your Mainboard version is older than 1.6.1, then follow the upgrading steps below.

Firmware Update

Step 1

Download the firmware-bin file

wget http://web.barrett.com/support/Burt_Documentation/FirmwareUpdate/mainboard-M0223.dev-mainboard-1.6.1-0-g3fce96e.bin

Step 2

Update your firmware

burt-util mainboard silence_can
burt-util flash 10 path/to/mainboard-M0223.dev-mainboard-1.6.1-0-g3fce96e.bin
burt-util reset 10

Step 3

Verify your Mainboard version again

burt-util mainboard get_versions

Step 4

If the BurtSharp source is not installed, clone the repository

git clone https://git.barrett.com/burt/software/burt-sharp.git

Step 5

Verify your BurtSharp version

cd <path-burt-sharp-repo>
cat BurtSharp/Properties/AssemblyInfo.cs | grep Version

If the version is not 2.3.1, check out the dev-2.3.1 tag

git checkout dev-2.3.1